ANA Technical Help

Technical Help

Before troubleshooting, please note that if you use a Macintosh or iPhone with an older version of OS, some functions on the ANA website may not work properly. We kindly request that you upgrade your OS to the latest version. For Macintosh, we recommend macOS v10.15. For your iPhone, you need iOS 13 or higher. Upgrade your Mac here and update your iOS here.

Strengthening of Security for the ANA Website

On February 19, 2020, we will be suspending versions TLS1.0 and TLS 1.1. Due to these changes in the way we handle encryption, ANA websites will no longer be available after 2:00 a.m. on February 19, 2020 JST (planned) to customers whose browser environment falls within the following:

  • Internet Explorer version 10.0 and older
  • Google Chrome version 29 and older
  • Firefox version 26 and older
  • Safari version 5 and older
  • Android browser version 4.4.4 and older
  • After February 19, if you try to view an ANA website under the above environment, a message will appear indicating that the page cannot be displayed (e.g., “Internet Explorer cannot display the webpage.”). This message will differ depending on your browser environment.

If necessary, please configure your browser environment for continued access to our services. If you do not upgrade your browser, you will not be able to view any web page with an “ana.co.jp” URL. We apologize for the inconvenience, and ask for your kind understanding.

How to Configure Your Browser

Internet Explorer

For Windows 7 or 8, communication using TLS 1.2 is available by doing the following:

  • Click “Tools,” then click “Internet Options” in the window.
  • Click the “Advanced” tab in the “Internet Options” window.
  • Check “Use TLS 1.2.”
  • Click “OK” to close and restart Internet Explorer.
ANA homepage screen with instructional notes
Firefox
  • Open Firefox.
  • Type “about: config” in the address bar.
  • If a warning such as "This might void your warranty" is displayed, select "I accept the risk."
  • Find the line “security.tls.version.max” and double click the line.
  • When “Enter integer value” is displayed on the screen, type “4”, and click “OK.”
  • Click “OK” to close the dialog box and restart the browser.
Android

If you have Android 4.4.4. or older, you will need the latest Android version. Please update to the latest version.

iOS

If you use iOS 4 or older, you will need to upgrade to the latest iOS. Please upgrade to the latest version.

Operating Environment for PC

Some contents of ANA Website are created using Javascript. Your browser is usually Javascript-enabled by default. We recommend a Javascript-enabled browser for viewing all the contents of ANA website. To easily navigate the ANA website securely, please use one of the following browsers.

Windows (excluding Windows RT):
  • Internet Explorer 11
  • Firefox 73
    • Excluding Windows Store App Edition
Macintosh:
  • Firefox 73
    • This website is not optimized for Internet Explorer of versions older than 11.0, non-IE browsers, or mobile devices.
    • Contact forms, FAQ pages and chats may be displayed incorrectly on some devices and on certain browsers and applications.

Upgrading Your Browser

Some functions may not be available if the website is viewed in each browser of a specific version as described below. To reserve flights/pay for air tickets, follow the operations below.

Internet Explorer 10.0
  • Select "Compatible Display Setting" from Tools in the menu bar.
  • When the Compatible Display Setting window appears, type "ana.co.jp" as the website to add, and then click the Add button.
  • When the setting is complete, the "ana.co.jp" website you have added appears in the Compatible Display field.
Safari 4.0.4 or later
  • From “Reset Safari,” select “Remove all website data” and close the browser.
  • Open the browser again, and start reservation without logging in to the top page of the ANA website (https://www.ana.co.jp).
  • On the flight selection screen, click the "Member" button to log in and continue with the operation.
  • Note: If you don’t want to remove all cookies in Safari 4.0.4:
    • From Preferences, go to Privacy and click the "Details" button under "Cookies and other website data."
    • Delete only the items which "Website" field shows ".ana.co.jp."
For customers using an older browser version
  • The site can be viewed/used in the same manner using relatively new software. If an older browser version is used. However, the page layout may break and the pages may not be displayed properly in some cases.
  • In creating the site, we take measures to ensure no information is missing or all pages are properly displayed regardless of the software used. However, it is still recommended that you use a web browser of the latest version as much as possible in order to view the site without experiencing any problem.

SHA-2 SSL Server Certification

  • For server certifications used in encrypted communication (SSL/TLS), there has been a worldwide movement towards using the SHA-2 encryption algorithm.
  • The algorithm is safer than SHA-1, which has been widely used up until this point. To provide greater peace of mind to all of our ANA website customers, we moved to SHA-2 certification on March 15, 2016.
  • With these changes, Windows XP Service Pack 2 users have been unable to view images or use services on the sites.
  • Customers using versions of Windows older than Windows XP Service Pack 2 will have difficulty viewing the ANA website.

Operating Environment for Smartphones/Tablets

ANA SKY MOBILE, an ANA site for smartphone users, will work on Androids and iPhones. SIM-free devices, MVNOs (Mobile Virtual Network Operators ), Android feature phones, tablets etc., are not applicable.

The following pre-installed Android browsers are acceptable:
  • Android browser
  • Chrome for Android (recommended)
The following pre-installed Android browsers are acceptable:
  • Please use the pre-installed Safari browser.

Note: Depending on your phone settings and available memory, there may be cases where the applicable devices do not function normally. Errors may occur with reservation-related functions on new cell phone models where changes have been made to pre-installed browsers. This information is correct as of March 9, 2017.

Notes

  • Even if your device has an appropriate operating environment, some pages may be displayed incorrectly or functions may be unavailable due to your combination of browser, OS, and Flash Player software.
    • This also includes the use of some add-ons and beta, preview or other such browser versions.
  • We are doing our share to support new browsers as they are released, but the display and operation may not be stable with new browsers due to browser-specific bugs that are not yet disclosed.
  • You need Adobe's Flash Player plug-in to access certain contents and functions.
  • A resolution of 1024 x 768 pixels or more (16 bits or more) and a medium font size is recommended for optimal viewing.